Issue with gwpy unable to plot the data

Hi everyone,
I am recently joined in this work and i have gone through the videos and workshop lectures. And i started work by downloading the L1 data from the GWOSC website, i have imported the all required libraries. When i supposed to plot the strain data I’m facing issues (AttributeError: type object ‘LatexInlineDimensional’ has no attribute ‘_latex_escape’). Can any one help me to figure out this problem(i tried updating the gwpy). Below I’m attaching the code picture.


Hi @sanjeev7881 !

I’m not really sure, but this looks like an issue related to software version numbers. You should check that the versions of gwpy, astropy, and matplotlib are consistent. For example, you could try to follow the version numbers in one of the conda distributions:


Check out this other thread with a similar issue:

Hi @sanjeev7881. I don’t know if you have solved it. I got the same error again with a google colab notebook, but then it worked by doing the following at the very beginning:
!pip install --upgrade gwpy

and comment the other lines:
– Uncomment following line if running in Google Colab
! pip install -q ‘gwpy==2.0.2’

Hope it helps :slight_smile:

Thank you all for your precious comments and i shorted it out now.