Help needed for Tutorial 2.1

Hello. I cannot run the jupyter notebook with PyCBC for tutorials 2.1 and 2.2. I get the following errors:

RuntimeError: module compiled against API version 0xe but this version of numpy is 0xd
and
ImportError: numpy.core.multiarray failed to import

I tried updating numpy but it did not work. Please help.

1 Like

Hi @Debika_Chowdhury , which settings are you using? Are you running it locally with conda or with google colab or with binder? Which operating system do you have (windows, mac or linux)?

I am running locally with conda in Ubuntu. I am using python 3.9 and I have set up my software as instructed in Option 3 of: odw-2022/setup.md at main · gw-odw/odw-2022 · GitHub

which version of pycbc and numpy do you have? are you sure you are using the igwn-py39 environment?

I am using PyCBC==1.18.0 and numpy==1.19.5. But you are right. My kernel got changed somehow, even though I was using igwn-py39 until the last tutorial. Thanks a lot, and sorry for the confusion.

ok, good that you solved it :slight_smile: